No Image

Узнать на какие сайты заходили через роутер

1 просмотров
11 марта 2020

В своей работе мне часто приходится использовать данные маршрутизаторы для решения своих задач. В данном случае, необходимо было предоставить доступ в интернет через роутер RB450G, имея возможность блокировать определенные сайты по маске имени и сохранять историю посещений. Далее будет показан пример решения такой задачи с использованием бесплатного ПО.

Для начала было решено настроить прозрачный прокси. В роутере есть свой Web-proxy, чтобы сделать его прозрачным выполняем согласно примеру в документации

code>ip firewall nat add in-interface=ether1 dst-port=80 protocol=tcp action=redirect to-ports=8080 chain=dstnat
ip proxy set enabled=yes port=8080

что перебрасывает запросы по 80(HTTP) порту на порт прокси сервера 8080. Теперь можно добавить блокируемые адреса, например так

/ip proxy access add action=deny redirect-to=192.168.0.1/404 dst-host=:facebook

В данном случае будут блокироваться запросы содержащие слово «facebook» и переадресовываться на внутреннюю страницу 192.168.0.1/404 (что конечно же необязательно). После двоеточия в параметре dst-host можно использовать и регулярные выражения.

Далее встал вопрос, как же, собственно накапливать и обрабатывать журнал посещений. Встроенного или иного продукта от производителя предусмотрено не было. После чтения документации и поиска по тематическим форумам был найден продукт Webproxy-log. Продукт несколько топорный, но подсказывающий направление (хотя для небольшой нагрузки и он вполне сгодится). Как это работает:
1. В настройке назначения журналирования добавляется раздел для предачи в syslog сервер.

/system logging action add name=proxylog target=remote remote=192.168.0.1 src-address=192.168.0.3

192.168.0.1 — адрес syslog сервера, в который мы будем направлять журнал. 192.168.0.3 — внутренний адрес маршрутизатора.
2. Создадим раздел самого журнала, который будет использовать созданное назначение и направлять туда логи прокси сервера
.
/system logging add topics=web-proxy action=proxylog

На этом этапе роутер будет отсылать логи вида

web-proxy,account 192.168.0.59 GET imgcdn.ptvcdn.net/pan_img/appDownload/PandoraService/Service_Info.
xml action=allow cache=MISS
web-proxy,debug GET /pan_img/appDownload/PandoraService/Service_Info.xml HTTP/1.1
web-proxy,debug Cache-control: no-cache
web-proxy,debug Pragma: no-cache
web-proxy,debug Host: imgcdn.ptvcdn.net
web-proxy,debug Accept: text/html, */*
web-proxy,debug Accept-Encoding: identity
web-proxy,debug User-Agent: Mozilla/3.0 (compatible; Indy Library)
web-proxy,debug X-Proxy-ID: 1074695054
web-proxy,debug X-Forwarded-For: 192.168.0.59
web-proxy,debug Via: 1.1 192.168.0.3 (Mikrotik HttpProxy)
web-proxy,debug

где с префикса web-proxy,account будет записан адрес пользователя пославшего запрос, и сам запрос.

Читайте также:  Как подключить джойстик от пс4 к компьютеру

3. В качестве сервера можно использовать вышеуказанный продукт, который состоит из двух частей:
WebProxy Log Catcher — приложение (как служба не устанавливается) сам простой syslog сервер, собирающий логи для последующей обработки и добавляющий метки времени.
WebProxy Log — интерфейс просмотра журналов, при каждом запуске импортирующий накопленные сборщиком логи в локальную БД.

Настройка приложения сложностей не вызывает и достаточно описана в документации.

Учтя несложный формат логов, не сложно написать свой анализатор журналов отправляемых маршрутизатором и позже для собственных целей была написана небольшая служба с вэб-интерфейсом, используя Delphi и компоненты ICS, сохраняющая журналы в бд на базе SQL server express.

Возможно, всё перечисленное поможет Вам сэкономить время при решении подобных задач и немного познакомит с возможностями маршрутизаторов данного производителя.

На какие сайты заходит мой ребенок? Этот вопрос рано или позно задают себе все папы и мамы, чье чадо, заполучив вожделенный Windows-компьютер или планшет, принялось со всей активностью осваивать все просторы и закоулки всемирной Сети, или как сейчас модно говорить «серфить» в Интернете.

И эффективно проконтролировать виртуальные похождения своего дитяти может далеко не каждый родитель, в особенности если ребенок уже умеет удалять историю в браузере своего компьютера.

Скажем сразу, если ваши сын или дочь кое-чего уже научились, и по крайней мере знают, как правильно использовать функции приватных режимов просмотра в Internet Explorer (InPrivate browsing mode) или Google Chrome (Incognito mode), то история посещений (т.е. на какие сайты заходил ребенок и какие страницы на этих сайтах просматривал), в этих браузерах сохраняться не будут.

Если же до такого ваш ребенок еще не додумался, и его не надоумили на это более продвинутые в техническом плане друзья, то проверить, на какие сайты он заходил, можно путем просмотра DNS кэша его ПК. Для это в командной строке устройства нужно набрать ipconfig /displaydns и нажать Enter.

Читайте также:  Гарантия на xiaomi с алиэкспресс

Данная команда позволяет оперативно получить перечень всех сайтов, на которые заходили с данного конкретного компьютера. Следует иметь в виду, что в списке буду содержаться не только те веб-страницы, на которые были прямые заходы с ПК вашего ребенка, но также косвенно доступный через такие страницы контент .

Таким контентом могут быть, к примеру, реклама или объявления сомнительного содержания, которые размещались на вполне приличных и безобидных сайтах. В этой связи, прежде чем выдвигать какие-либо обвинения, следует грамотно разобраться с полученной информацией.

Страницы, на которые были прямые заходы с ПК в списке, полученном через команду ipconfig /displaydns, отображаются как правило с знакомым всем «www.», однако не всегда.

Более надежный, но несколько более сложный способ мониторинга онлайн-деятельности вашего ребенка состоит в том, чтобы настроить ваш домашний роутер на сохранение его собственных логов через систему SysLog. Это позволит сохранять историю посещений всех подключенных к вашей домашней сети компьютеров (смартфонов и планшетов), притом записи нельзя будет удалить просто так, без административного доступа к вашему роутеру.

Функция SysLog предусмотрена практически в каждом современном маршрутизаторе, одна для ее эффективной реализации необходимы определенные знания, к тому же в разных моделях роутеров настраивается она по-разному. Тем не менее, в некоторых случаях необходимость понимать, на какие сайты ходит ребенок, и более жестко контролировать его онлайн-прогулки стоит того, чтобы почитать инструкцию к роутеру и озадачить поисковик на предмет пошаговой настройки SysLog для данной модели.

Чуть более простой вариант мониторинга веб-серфинга — это такие сравнительно несложные в использовании онлайн-сервисы как, к примеру, OpenDNS, позволяющие предотвращать доступ пользователей одного или нескольких компьютеров к нежелательному содержимому сайтов, защищать компьютеры от вирусов, распространяемого через интернет, получать релевантны результаты поиска по интернету при запросе несуществующего адреса сайта или сайта, временно недоступного из-за сбоев, и пр. Однако об OpenDNS мы расскажем в одной из следующих статей.

Читайте также:  Зависает компьютер на несколько секунд потом нормально

C помощью интернет-фильтра SkyDNS можно посмотреть статистику самых популярных сайтов, обращения к которым были совершены с компьютеров домашней сети, при работе через интернет-центр Keenetic. Данная возможность доступна даже на бесплатном тарифе Free.

Получить подробную информацию о сервисе SkyDNS, а также инструкцию по его настройке в интернет-центрах Keenetic можно в статье: "Интернет-фильтр SkyDNS".

На сайте www.skydns.ru в Личном кабинете зайдите в раздел "Статистика". При использовании бесплатного тарифа Free сервис SkyDNS собирает статистику посещенных и заблокированных веб-ресурсов за один месяц работы (на других тарифах этот срок может составлять 6 месяцев или 1 год). Статистическая информация на сервисе обновляется примерно один раз в час.

На вкладке "Активность" можно посмотреть количество DNS-запросов, отправленных с ваших компьютеров, за определенный период (возможные варианты — Сегодня, Вчера, Неделя, Месяц, Диапазон), а также почасовой график запросов.

На вкладке "Популярные" показан список сайтов, к которым было больше всего обращений с ваших компьютеров. В виде графика Топ-10 отображаются самые популярные сайты.

На вкладке "Заблокированные" показан список сайтов, которые были заблокированы сервисом SkyDNS. В виде графика Топ-10 отображаются заблокированные сайты с наибольшим количеством обращений.

На вкладке "Категории" показана диаграмма (Топ-10), отражающая самые популярные категории сайтов, к которым совершались обращения.

Пользователи, считающие этот материал полезным: 4 из 5

Комментировать
1 просмотров
Комментариев нет, будьте первым кто его оставит

Это интересно
No Image Компьютеры
0 комментариев
No Image Компьютеры
0 комментариев
No Image Компьютеры
0 комментариев
No Image Компьютеры
0 комментариев
Adblock detector